Back to overview
Degraded
there was downtime of xservice
Mar 06, 2026 at 09:08am UTC
Affected services
Manually tracked item - xservice
Manually tracked item xdana test
Resolved
Mar 12, 2026 at 08:52am UTC
All services are back online
Affected services
Created
Mar 06, 2026 at 09:08am UTC
2 hours downtime of our precious xservices
Affected services